Not ready to move to Phantasm v4?

Phantasm v4 is released today (18th April 2018) with its biggest update in 12 years bringing a new Phantasm Panel for intuitive colour control and a new Vector Halftone clipping option among other highlights.

In line with our usual perpetual licensing model, if you are already a Phantasm customer, discounted upgrades will be available for 1 month from the release date. To claim your Phantasm v4 discount coupon, you will need to purchase within this 1 month offer period, ensuring that you're logged into your customer account when making your purchase.

 

Remaining with Phantasm v3

If you're not ready to upgrade to version 4, you do have the option to remain with version 3. When installing other plug-ins, simply follow these steps (as circled in green below):

  • On the installer step that lists all the plug-ins available to install, leave the box next to Phantasm unticked.
  • You will see the option to “Keep version 3 ”
  • Now click on Install to confirm

(Please note that this won't be possible if you have moved on to CC2019 as Phantasm v3 isn't compatible with this version of Illustrator. If you have now moved beyond CC2018, please refer to the 'Installed Phantasm v4 by mistake?' or 'Reinstall Phantasm v3' advice below)

Remaining with Phantasm v3

Installed Phantasm v4 by mistake?

If you have accidentally installed a Phantasm v4 trial by mistake, you can revert to your Phantasm v3 version by uninstalling version 4 (see Guide to Uninstalling ) and then reinstalling using the last Astute Graphics Unified Installer to contain Phantasm v3 (Illustrator CS6 to CC2018) provided below.
To do this it will be necessary to maintain an older version of Illustrator (suggested C2017 or CC2018) in parallel with your latest Cloud-based version. Please refer to Adobe's documentation on how to do this.

Mac OS:

https://astutegraphics.com/downloads/astute-graphics-unified-installer-v1-3-1-mac.dmg

Windows:

https://astutegraphics.com/downloads/astute-graphics-unified-installer-v1-3-1-windows.zip

 

Phantasm v4_night_city_banner

Reinstalling Phantasm v3

If you would like to remain with Phantasm v3 it will be necessary to revert to an older Illustrator version, or maintain an older version of Illustrator (suggested C2017 or CC2018) in parallel with your latest version. Please refer to Adobe's documentation on how to do this.

This will enable you to reinstall your old Phantasm v3 license on this older version of Illustrator using one of the legacy installers provided below.

Mac OS:

https://astutegraphics.com/downloads/astute-graphics-unified-installer-v1-3-1-mac.dmg

Windows:

https://astutegraphics.com/downloads/astute-graphics-unified-installer-v1-3-1-windows.zip

 

Full step by step instructions on installing and activating are available in our Installation Guide.

Please also see Maintaining or Reinstalling Previous Generation Plug-ins

Pin It on Pinterest

Share This
0

Your Cart