Support

Continuing to use your legacy plugins in CC2019

2 minute read • Last updated 2019-11-07

If you are a legacy user and you’re not ready to move to the Annual Service Plan, please note that our legacy software is NOT Illustrator 2020 compatible. To continue using your legacy plugins you will need to run CC2019 alongside Illustrator 2020. Legacy licenses remain valid and available for Adobe Illustrator CS6 to CC2019 on both Windows 7 / 8.1 / 10 and macOS 10.10 through 10.14, read more here.

If you have accidentally uninstalled Illustrator CC2019, you can reinstall from the download available here.
If you have yet to install 2020, then when upgrading you will need to select to keep your previous version (CC2019) also. To do this you will need to go into the advanced options and ensure that “Remove old versions” is deselected (as of this new Illustrator release, this should be deselected by default). To do so, please do the following:

  • When viewing the Creative Cloud App versions available to you, select the little three dots submenu (circled in red here) at the bottom of your currently installed version:
  • Select "Other versions”:


  • Click on "Install"
  • Now ensure that “Remove old versions” is unchecked before clicking on “Continue"
  • You can now run CC2019 alongside Illustrator 2020 to continue using your legacy plugins. 









Helpful?

Please explain why this isn't helpful*