Support

Is your software compatible with my version of Adobe Illustrator?

1 minute read • Last updated 2019-10-11

All of our plugins currently have the following software requirements:

Macintosh

Illustrator CC17.1 - CC2019

MacOS 10.10 to 10.14

Windows

Adobe Illustrator CC17.1 - CC2019

Windows 10/8/7

In September 2018 we reached the end of the support line for Mac OS 10.8 and in September 2019 we reached the end of the support line for CS6, you can read more about this here.

Helpful?

Please explain why this isn't helpful*